В вышедшей предварительной сборке Android 15 Developer Preview 2 Google ввела новые ограничения на установку приложений, разработанных для более ранних версий операционной системы. Об этом сообщает Rozetked со ссылкой на журналиста Мишаала Рахмана.

Как обнаружил эксперт, новая версия ОС не позволяет устанавливать приложения с версией SDK ниже 24, что соответствует Android 7.0 Nougat. Это означает, что приложения, написанные для Android 6.0 Marshmallow и более старых версий, не могут быть установлены на устройствах с Android 15.

Однако Рахман отметил, что существует способ обхода этого ограничения с помощью ADB-команды: «adb install --bypass-low-target-sdk-block .apk», где перед «.apk» нужно вписать название устанавливаемого пакета. Этот метод позволяет вручную установить нужное приложение, даже если оно больше не соответствует новым требованиям безопасности.

Google продолжает политику ограничения использования устаревших приложений в целях повышения безопасности. Начиная с августа 2023 года Google Play также перестал принимать к публикации приложения с SDK ниже версии 33 (Android 13). Компания объясняет, что такие приложения не обладают необходимыми современными мерами безопасности и могут быть использованы злоумышленниками.

Media.az